欢迎光临
专业期货策略平台

程序化趋势分析主图指标

大家好,今天给大家带来的是程序化趋势分析主图指标,可以应用在通达信软件上,也可以在博易云软件上使用,如果有想在文华财经软件上使用了也可以自己转化,相对来说难度不是很高,下面就来看一下具体指标吧。

AVX:=(((((IF(C>MA(C,5),10,(0-10))+IF(MA(C,5)>MA(C,10),10,(0-10)))+IF(C>MA(C,10),10,(0-10)))+IF(MA(C,5)>MA(C,20),10,(0-10)))+IF((C>MA(C,20)),10,(0-10)))+IF

  MA(C,20)>REF(MA(C,20),1),10,(0-10)));

  DSLX:=(C/INDEXC);

  DSLX1:=MA(DSLX,5);

  TJTS1:=BARSTATUS=2 AND C

  TJTS2:=BARSTATUS=2 AND C>200;

  V1:=MA(V,3);

  V2:=MA(V,8);

  K2:=HHV(H*0.99,BARSLAST(BARSTATUS=1));

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'量能稳定,有走强迹象,根据指数线性关系布局分批介入. '),COLORRED,LINETHICK1;

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1=DSLX1)),0.5,0,0,'走势趋强,量能不足,根据指数线性关系布局分批买入. '),COLORRED,LINETHICK1;

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1>V2)) AND (DSLX

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'形态变坏,减持或者卖出观望. '),COLORGREEN,LINETHICK2;

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1=DSLX1)),0.5,0,0,'明显缩量走势,根据指数线性关系减持或清仓,等待机会. '),COLORWHITE,LINETHICK1;

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1>=V2)) AND (DSLX

  DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1

  DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'强势明显,量能充足,注意前期平台和指数影响. '),COLORRED,LINETHICK1;

  DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1=DSLX1)),0.5,0,0,'强势依然,量能转弱,高抛低吸做好布局. '),COLORCYAN,LINETHICK2;

  DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1>=V2)) AND (DSLX

  DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1

  DRAWTEXT_FIX(TJTS1 AND ((((AVX=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'形态不佳,注意量能变化,跟踪分析确认. '),LINETHICK2;

  DRAWTEXT_FIX(TJTS1 AND ((((AVX=DSLX1)),0.5,0,0,'走势虽弱,关注线性关系和量能变化,确认业绩、题材. '),COLORYELLOW,LINETHICK2;

  DRAWTEXT_FIX(TJTS1 AND ((((AVX=V2)) AND (DSLX

  DRAWTEXT_FIX(TJTS1 AND ((((AVX

  DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1>=V2)),0.5,0,0,'量能稳定,有明显走强迹象,可以考虑布局. '),COLORWHITE,LINETHICK2;

  DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1>=V2)),0.5,0,0,'如前期经过一轮下跌,此时为最佳买点,但前期有过一段涨幅则介入需谨慎. '),COLORWHITE,LINETHICK2;

  DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1

  DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1

  DRAWTEXT_FIX(TJTS2 AND (CROSS(1,AVX) AND (V1>=V2)),0.5,0,0,'大盘形态走坏,减仓或者抛光. '),COLORGREEN,LINETHICK2;

  DRAWTEXT_FIX(TJTS2 AND (CROSS(1,AVX) AND (V1

  DRAWTEXT_FIX(TJTS2 AND (((AVX>=1) AND (REF(AVX,1)>0)) AND (V1>=V2)),0.5,0,0,'走势良好,量能稳定,可以继续持有强势股. '),COLORWHITE,LINETHICK2;

  DRAWTEXT_FIX(TJTS2 AND (((AVX>=1) AND (REF(AVX,1)>0)) AND (V1

  DRAWTEXT_FIX(TJTS2 AND (((AVX=V2)),0.5,0,0,'趋势不明,注意量能和线性关系变化,减少操作. '),LINETHICK2,COLORWHITE;

  DRAWTEXT_FIX(TJTS2 AND (((AVX

  RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

  K1:=SMA(RSV,3,1);

  D1:=SMA(K1,3,1);

  高1:=HHV(H,150);

  低1:=LLV(L,150);

  QR:=(H+L+2*C)/4;

  强弱分界线:=EMA(QR,55),COLORFFFF00;

  TFXXS:=INTPART(K1)+INTPART(D1);

  TGL:=(TFXXS-REF(TFXXS,1));

  DRAWTEXT_FIX(ISLASTBAR AND TGL>=0 AND TGL>REF(TGL,1),0.99,0.01,1,'资金状况:流入加快'),COLOR0202FF;

  DRAWTEXT_FIX(ISLASTBAR AND TGL>=0 AND TGL

  DRAWTEXT_FIX(ISLASTBAR AND TGLREF(TGL,1),0.99,0.01,1,'资金状况:流出减慢'),COLOR13B79A;

  DRAWTEXT_FIX(ISLASTBAR AND TGL

  VAR1E:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

  VAR2E:=SMA(ABS(LOW-VAR1E),13,1)/SMA(MAX(LOW-VAR1E,0),10,1);

  VAR3E:=EMA(VAR2E,10);

  VAR4E:=LLV(LOW,33);

  VAR5E:=EMA(IF(LOW

  VAR21E:=SMA(ABS(HIGH-VAR1E),13,1)/SMA(MIN(HIGH-VAR1E,0),10,1);

  VAR31E:=EMA(VAR21E,10);

  VAR41E:=HHV(HIGH,33);

  VAR51E:=EMA(IF(HIGH>=VAR41E,VAR31E,0),3);

  DRAWTEXT_FIX(ISLASTBAR AND VAR51E

  DRAWTEXT_FIX(ISLASTBAR AND VAR5E>REF(VAR5E,1),0.99,0.15,1,'典型吸筹行为'),COLOR1876E9;

  DRAWTEXT_FIX(ISLASTBAR AND VAR5E

  DRAWTEXT_FIX(ISLASTBAR AND VAR5E=REF(VAR5E,1),0.99,0.15,1,'无特殊行为'),COLORC0C0C0;

  DRAWTEXT_FIX(ISLASTBAR AND VAR51E>REF(VAR51E,1),0.99,0.08,1,'主力正在出货'),COLOR00CA00;

  DRAWTEXT_FIX(ISLASTBAR AND VAR51E=REF(VAR51E,1),0.99,0.08,1,'主力无大动作'),COLORC0C0C0;

  DRAWTEXT_FIX(CURRBARSCOUNT=120,0.6,4.01,0),COLORGREEN;

  VAR78:=C/EXPMA(C,5);

  A1:=COST(1.91);

  A2:=COST(3.82);

  A3:=COST(5);

  A4:=COST(6.18);

  A5:=COST(8.09);

  COSTT:=(A1+A2+A3+A4+A5)/5;

  COSTT1:=C/COSTT;

  VARD1:=(2*INDEXC+INDEXH+INDEXL)/4;

  VARD2:=LLV(INDEXL,21);

  VARD3:=HHV(INDEXH,8);

  MIJI:=EMA((VARD1-VARD2)/(VARD3-VARD2)*100,9);

  MIJI1:=MIJI-VAR78;

  MIJI2:=MIJI1-REF(MIJI1,1);

  MIJI3:=MIJI-REF(MIJI,1);

  DAPAN:=COSTT1-(MIJI3+0.618*MIJI2)/16.18;

  DRAWTEXT_FIX(ISLASTBAR AND DAPAN

  DRAWTEXT_FIX(ISLASTBAR AND DAPAN>=COSTT1,0.99,0.8,1,'受大盘压制'),COLOR00CA00;

  X1E:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

  X2E:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;

  X3E:=FINANCE(23)/FINANCE(10)*3.3;

  X4E:=FINANCE(19)/FINANCE(15)*0.6;

  X5E:=FINANCE(20)/FINANCE(15)*0.999;

  YAOGU:=X1E+X2E+X3E+X4E+X5E;

  XJF:=CON2STR(FINANCE(25)/FINANCE(15),3);

  YZZ:=CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2);

  DRAWTEXT_FIX(YAOGU

  DRAWTEXT_FIX(YAOGU>0 AND YAOGU

  DRAWTEXT_FIX(YAOGU>1.2 AND YAOGU

  DRAWTEXT_FIX(YAOGU>2.6 AND YAOGU

  DRAWTEXT_FIX(YAOGU>5.8,0.99,0.99,1,'拉升潜力:轻而易举'),COLOR0000FF;

  DRAWTEXT_FIX(XJF>=1618,0.99,0.86,1,'过于保守'),COLOR4747B8;

  DRAWTEXT_FIX(XJF>=618 AND XJF

  DRAWTEXT_FIX(XJF>=100 AND XJF

  DRAWTEXT_FIX(XJF

  DRAWTEXT_FIX(YZZ

  快线:=EMA(C,7)-EMA(C,21),LINETHICK2,COLORRED;

  慢线:=MA(快线,4),COLORGREEN,LINETHICK2;

  数值:=EMA((0.668*REF(快线,1)+0.333*快线),1),COLORSTICK;

  X1:=V/SUM(V,13);

  X2:=DMA(C,X1);

  X3:=(C-X2)/X2*40;

  L2:=MA(AMOUNT/(100*V),13);

  CYS13:= (C-L2)/L2*100;

  做多:=IF(快线>=数值,快线,数值);

  做空:=IF(数值-快线,数值,快线);

  强庄:STICKLINE(CYS13>5,L-0.22,L-0.35,2,0),COLORCYAN;

  AAA:=(3*C+H+L+O)/6;

  VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;

  VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/0;

  VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;

  VAR4:=(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/0;

  VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;

  VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;

  IF((VAR1

  IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;

  STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE;

  DRAWKLINE(H,O,L,C);

  DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5

  DRAWTEXT(REF(VAR6,1)=REF(VAR1,1) AND VAR6

  CC:=((HIGH+LOW+CLOSE)/3-EMA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));

  STICKLINE(CC>=0,LOW,HIGH,0.0,0),COLORRED;

  STICKLINE(CC>=0,CLOSE,OPEN,3,1),COLORRED;

  STICKLINE(CC

  STICKLINE(CC

  月DI:="MACD.DIF#MONTH";

  月DE:="MACD.DEA#MONTH";

  周DI:="MACD.DIF#WEEK";

  周DE:="MACD.DEA#WEEK";

  日DI:="MACD.DIF";

  日DE:="MACD.DEA";

  日金叉:=CROSS(日DI,日DE);

  周金叉:=CROSS(周DI,周DE);

  月金叉:=CROSS(月DI,月DE);

  日穿0:=CROSS(日DI,0);

  周穿0:=CROSS(周DI,0);

  月穿0:=CROSS(月DI,0);

  DRAWTEXT(日穿0,LOW-0.48,'↖日穿0'),COLORCYAN;

  DRAWTEXT(周穿0,L*0.94,'↖周穿0'),COLORCYAN;

  DRAWTEXT(月穿0,L*0.99,'↖月穿0'),COLORCYAN;

  DRAWTEXT(日金叉,LOW-0.3,'↖日金叉'),COLORCYAN;

  DRAWTEXT(周金叉,L*0.92,'↖周金叉'),COLORCYAN;

  DRAWTEXT(月金叉,L*0.90,'↖月金叉'),COLORCYAN;

  MA2:=EMA(C,2);

  MA05:=EMA(C,5);

  MA010:=EMA(C,10);

  MA020:=EMA(C,20);

  MA030:=EMA(C,30);

  YC0X:=MA05>=REF(MA05,1);

  H01:=MAX(MAX(MA05,MA010),MA020);

  L01:=MIN(MIN(MA05,MA010),MA020);

  一穿三线:=H01REF(MA2,1);

  STICKLINE(一穿三线,O,C,0.3,0),COLORYELLOW;

  DRAWTEXT(一穿三线,L-0.62, '←穿三线'),COLORGREEN;

  总额:=AMOUNT;

  买A:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

  买%:=买A/AMOUNT*100;

  净流:=(流入-流出);

  总额3:=SUM(AMOUNT,3);

  流入3:=SUM(流入,3);

  流出3:=SUM(流出,3);

  净流3:=SUM(流入-流出,3);

  总额5:=SUM(AMOUNT,5);

  流入5:=SUM(流入,5);

  流出5:=SUM(流出,5);

  净流5:=SUM(流入-流出,5);

  总额10:=SUM(AMOUNT,10);

  流入10:=SUM(流入,10);

  流出10:=SUM(流出,10);

  净流10:=SUM(流入-流出,10);

  画:=CONST(FINDHIGH(总额10,0,190,1));

  DRAWTEXT_FIX(1,0,0.37,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;

  DRAWTEXT_FIX(1,0,0.45,0,'1日'),COLORMAGENTA,LINETHICK1;

  DRAWTEXT_FIX(1,0,0.55,0,'3日'),COLORMAGENTA,LINETHICK1;

  DRAWTEXT_FIX(1,0,0.65,0,'5日'),COLORMAGENTA,LINETHICK1;

  DRAWTEXT_FIX(1,0,0.75,0,'10日'),COLORMAGENTA,LINETHICK1;

  DRAWNUMBER_FIX(1,0.05,0.45,0,CONST((净流))),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.05,0.55,0,CONST((净流3))),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.05,0.65,0,CONST((净流5))),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.05,0.75,0,CONST((净流10))),COLORYELLOW;
0 0 vote
Article Rating
Click to rate this post!
[Total: 0 Average: 0]
赞(1) 打赏
未经允许不得转载:A期客 » 程序化趋势分析主图指标
订阅
提醒
guest
0 评论
Inline Feedbacks
View all comments

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

0
Would love your thoughts, please comment.x
()
x