欢迎光临
专业期货策略平台

期货金字塔顶底指标模型源代码下载

VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1) 100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1) 100;
VAR6:=VAR5-VAR2;
趋势: IF(VAR6>45,VAR6-45,0);
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2,0),COLORMAGENTA;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2,0),COLORGREEN;
强弱分界:50,COLORFFFFCC;
底部:0,COLOR00FFFF;
安全:20,COLORFFAA66,LINETHICK1;
预警:80,COLORFFAA66,LINETHICK1;
顶部:100,COLORFFFF33;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
DRAWTEXT(CROSS(价位线,0.3),20 4,\'●买\'),COLORRED;
DRAWTEXT(CROSS(3.5,价位线),100-4,\'●卖\'),COLORGREEN;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,3,1),COLORYELLOW;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
主力线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*
SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK1,POINTDOT;
超短线:(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORLIRED;
VAR11:=3;
VAR21:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
股价准备启动:IF(CROSS(VAR21,VAR11),100,0),COLORRED,LINETHICK2;

期货金字塔模型解析:

VAR1赋值:(9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100-70
VAR2赋值:VAR1的9日[1日权重]移动平均 100
VAR3赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR4赋值:VAR3的3日[1日权重]移动平均
VAR5赋值:VAR4的3日[1日权重]移动平均 100
VAR6赋值:VAR5-VAR2
输出趋势: 如果VAR6>45,返回VAR6-45,否则返回0
当满足条件昨日趋势<趋势时,在趋势和昨日趋势位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色
当满足条件昨日趋势>趋势时,在趋势和昨日趋势位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
输出强弱分界:50,COLORFFFFCC
输出底部:0,COLOR00FFFF
输出安全:20,COLORFFAA66,线宽为1
输出预警:80,COLORFFAA66,线宽为1
输出顶部:100,COLORFFFF33
V1赋值:10日内最低价的最低值
V2赋值:25日内最高价的最高值
价位线赋值:(收盘价-V1)/(V2-V1)*4的4日指数移动平均
当满足条件价位线上穿0.3时,在20 4位置书写文字,画红色
当满足条件3.5上穿价位线时,在100-4位置书写文字,画绿色
VAR2Q赋值:昨日最低价
VAR3Q赋值:最低价-VAR2Q的绝对值的3日[1日权重]移动平均/最低价-VAR2Q和0的较大值的3日[1日权重]移动平均*100
VAR4Q赋值:如果收盘价*1.3,返回VAR3Q*10,否则返回VAR3Q/10的3日指数移动平均
VAR5Q赋值:30日内最低价的最低值
VAR6Q赋值:30日内VAR4Q的最高值
VAR7Q赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR8Q赋值:如果最低价<=VAR5Q,返回(VAR4Q VAR6Q*2)/2,否则返回0的3日指数移动平均/618*VAR7Q
VAR9Q赋值:如果VAR8Q>100,返回100,否则返回VAR8Q
输出吸筹:当满足条件VAR9Q>-120时,在0和VAR9Q位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
AA3赋值:(21日内最高价的最高值-收盘价)/(21日内最高价的最高值-21日内最低价的最低值)*100-10
AA4赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
AA5赋值:AA4的13日[8日权重]移动平均
走势赋值:AA5的13日[8日权重]移动平均的向上舍入
AA6赋值:AA3的21日[8日权重]移动平均
输出卖临界:当满足条件走势-AA6>85时,在103和100位置之间画柱状线,宽度为15,1不为0则画空心柱.,画红色,线宽为2
主力线赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均,线宽为1,POINTDOT
输出超短线:(((主力线-21日内主力线的最低值)/(21日内主力线的最高值-21日内主力线的最低值))*(4))*(25),线宽为2,画淡红色
VAR11赋值:3
VAR21赋值:(3)*(((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*(100)的5日[1日权重]移动平均) – (2)*(((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*(100)的5日[1日权重]移动平均的3日[1日权重]移动平均)
输出股价准备启动:如果VAR21上穿VAR11,返回100,否则返回0,画红色,线宽为2

0 0 vote
Article Rating
Click to rate this post!
[Total: 1 Average: 3]
赞(0) 打赏
未经允许不得转载:A期客 » 期货金字塔顶底指标模型源代码下载
订阅
提醒
guest
0 评论
Inline Feedbacks
View all comments

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

0
Would love your thoughts, please comment.x
()
x